当前位置: > Linux教程 > Linux学习 >

Linux下的g77编译器安装

时间:2016-06-04 17:01来源:linux.it.net.cn 作者:IT
现在编译器变化很快,一不小心就落后于时代。
 
过去的不少程序都是用g77编译的,在新的Linux系统下,g77已经被gfortran完全替代了。然而,问题是gfortran并不能完全兼容过去的g77,完成修改程序似乎也是个不大可能的任务。。无奈,只好已业余者的身份自己摸索。
 
我用的是Ubuntu 10.10,可以自动安装新版gcc(但是已经没有了g77)。我是用如下方法安装g77的。
 
首先变成root用户: sudo bash
 
1. 在/etc/apt/source.list中最后头添加如下源(以root的身份,或用 sudo):
 
deb http://hu.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://hu.archive.ubuntu.com/ubuntu/ hardy universe
deb http://hu.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb-src http://hu.archive.ubuntu.com/ubuntu/ hardy-updates universe
 
2. 安装aptitude
sudo apt-get install aptitude
 
3. 然后执行如下:
 
sudo aptitude update
sudo aptitude install g77
 
4. 现在用g77就可编译我原来的程序了。

 
(责任编辑:IT)
------分隔线----------------------------
栏目列表
推荐内容