• 解决find: paths must precede expression

    日期:

    今天在服务器上执行find ./ -mtime +30 -type f -name *.php的时候,报下面的错误: find: paths must precede expression Usage: find [-H] [-L] [-P] [path...] [expression] 然后就上网查了一下,结果搜索到一篇,大概是这样说的:多文件的查找的时候需要增加单...

  • 解决ZoneMinder的filters不执行

    日期:

    今天在群里说起ZoneMinder,我发现我的ZoneMinder监控记录的资源占用空间有点大,如下: 然后MOTU给我说可以使用ZoneMinder的filters来指定时间来删除记录,释放硬盘空间,但我做好配置后,提交执行居然没有变化,问了MOTU后才知道有可能是ZoneMinder v1.25.0的bug....

  • 解决yum出现“UnicodeDecodeError: 'ascii' codec”

    日期:

    今天新装的一台服务器,打算用yum安装gcc等程序,出现下面的问题: Loading mirror speeds from cached hostfile Traceback (most recent call last): File /usr/bin/yum, line 29, in module yummain.user_main(sys.argv[1:], exit_code=True) File /usr/share/...

  • 解决bundle install安装问题

    日期:

    今天同事又来跟我纠结ruby和rails这台服务器的问题,今天他说执行bundle install的时候报下面的错误,如图 好嘛,继续网上给他找解决办法. 解决办法: 因为我们这台是编译安装的,所以执行: gem install io-console 如果是yum安装的话,可以执行: yum install ruby-...

  • linux安装rails失败的解决办法

    日期:

    其实当ruby安装成功后,然后在gem install --no-ri --no-rdoc rails的时候,报出了下面的错误: 01 Fetching: thread_safe-0.3.4.gem (100%) 02 Successfully installed thread_safe-0.3.4 03 Fetching: minitest-5.5.1.gem (100%) 04 Successfully installed mi...

  • 解决linux编译ruby1.8.7错误

    日期:

    今天同事要求在测试机上安装ruby和rails的时候,居然安装ruby-1.8.7出现编译错误.如下: ossl_pkey_ec.c:815: error: EC_GROUP_new_curve_GF2m undeclared (first use in this function) ossl_pkey_ec.c:815: error: (Each undeclared identifier is reported...

  • 解决jenkins自动杀掉衍生进程

    日期:

    公司要求用jenkins来自动部署nodejs的代码,当我用docker把jenkins和node整合到一起,用jenkins自动构建的时候,我才发现jenkins每次构建完了后要自动杀掉我的node部署shell脚本,网上到处找解决办法,花了三个工作日终于解决问题了. 软件版本: jenkins 1.651.2 n...

  • 解决centos服务器异常断电mysql启动异常启动Mysql时报错:mysqld_safe mysqld from pid file /usr/local/my

    日期:

    现象: centos服务器异常断电MySQL启动异常启动Mysql时报错:mysqld_safe mysqld from pid file /usr/local/mysql/Linux.pid end 但是打开日志文件 查看 InnoDB: Completed initialization of buffer pool InnoDB: Error: log file ./ib_logfile0 is of diffe...

  • 解决centos运行程序找不到libstdc++.so.6错误方案

    日期:

    运行程序时遇到找不到libstdc++.so.6问题原因: 系统是64bit,该库是32bit的,在64bit系统上安装32bit库 解决办法: 1. 查看哪个安装包包含该库:yum provides libstdc++.so.6 libstdc++-4.4.7-4.el6.i686 2. 安装 libstdc++-4.4.7-4.el6.i686 yum install li...

  • 真正解决W10: Warning: Changing a readonly file,E45: 'readonly' option is set (add ! to override)

    日期:

    大家在linux上编辑文件的时候,明明是使用的root登录的,可是这种至高无上的权限在按下i的时候被那串红色错误亵渎了W10: Warning: Changing a readonly file 抱着试试看的态度更改了文件,保存的那一刻又被一串红色错误E45: readonly option is set (add ! t...